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Legal Notices

This Documentation, which includes embedded help systems and electronically distributed 
materials (hereinafter referred to as the “Documentation”), is for your informational pur-
poses only and is subject to change or withdrawal by erwin Inc. at any time. This Docu-
mentation is proprietary information of erwin Inc. and may not be copied, transferred, 
reproduced, disclosed, modified or duplicated, in whole or in part, without the prior written 
consent of erwin Inc.  

If you are a licensed user of the software product(s) addressed in the Documentation, you 
may print or otherwise make available a reasonable number of copies of the Docu-
mentation for internal use by you and your employees in connection with that software, 
provided that all erwin Inc. copyright notices and legends are affixed to each reproduced 
copy. 

The right to print or otherwise make available copies of the Documentation is limited to the 
period during which the applicable license for such software remains in full force and effect. 
Should the license terminate for any reason, it is your responsibility to certify in writing to 
erwin Inc. that all copies and partial copies of the Documentation have been returned to 
erwin Inc. or destroyed. 

TO THE EXTENT PERMITTED BY APPLICABLE LAW, ERWIN INC. PROVIDES THIS 
DOCUMENTATION “AS IS” WITHOUT WARRANTY OF ANY KIND, INCLUDING WITHOUT 
LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE, OR NONINFRINGEMENT. IN NO EVENT WILL ERWIN INC. BE LIABLE 
TO YOU OR ANY THIRD PARTY FOR ANY LOSS OR DAMAGE, DIRECT OR INDIRECT, FROM 
THE USE OF THIS DOCUMENTATION, INCLUDING WITHOUT LIMITATION, LOST PROFITS, 
LOST INVESTMENT, BUSINESS INTERRUPTION, GOODWILL, OR LOST DATA, EVEN IF ERWIN 
INC. IS EXPRESSLY ADVISED IN ADVANCE OF THE POSSIBILITY OF SUCH LOSS OR DAMAGE. 

The use of any software product referenced in the Documentation is governed by the applic-
able license agreement and such license agreement is not modified in any way by the terms 
of this notice. 

The manufacturer of this Documentation is erwin Inc. 

Provided with “Restricted Rights.” Use, duplication or disclosure by the United States Govern-
ment is subject to the restrictions set forth in FAR Sections 12.212, 52.227-14, and 52.227-19
(c)(1) - (2) and DFARS Section 252.227-7014(b)(3), as applicable, or their successors. 

Copyright © 2020 erwin Inc. All rights reserved. All trademarks, trade names, service 
marks, and logos referenced herein belong to their respective companies. 
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Contact erwin
Understanding your Support

Review support maintenance programs and offerings.

Registering for Support

Access the erwin support site and click Sign in to register for product support.

Accessing Technical Support

For your convenience, erwin provides easy access to "One Stop" support for all editions of 
erwin Data Modeler, and includes the following:

Online and telephone contact information for technical assistance and customer ser-
vices 

Information about user communities and forums 

Product and documentation downloads  

erwin Support policies and guidelines  

Other helpful resources appropriate for your product  

For information about other erwin products, visit http://erwin.com/products.

Provide Feedback

If you have comments or questions, or feedback about erwin product documentation, you 
can send a message to techpubs@erwin.com.

erwin Data Modeler News and Events

Visit www.erwin.com to get up-to-date news, announcements, and events. View video 
demos and read up on customer success stories and articles by industry experts.

https://erwinhelp.zendesk.com/hc/en-us
https://erwinhelp.zendesk.com/hc/en-us
https://support.erwin.com/hc/en-us/categories/360002276332-erwin-Data-Modeler-Mart-Web-Portal
http://erwin.com/products/
mailto:techpubs@erwin.com
http://erwin.com/
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Introduction

The Feature Tour guide walks Data Architects, Data Administrators, Application Admin-
istrators, Database Administrators, and Partners through the features introduced in erwin 
Data Modeler 2020 R1 release.

The features and enhancements introduced in this release are:

erwin Data Modeler UI Facelift

erwin DM Scheduler

Productivity Enhancements

Query Tool

Licensing

DBMS Support

For additional information about a feature, in erwin Data Modeler, click Help on the toolbar 
or press F1 to navigate to the online help.
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erwin Data Modeler UI Facelift

erwin Data Modeler (DM) 2020 R1 comes with a brand new Microsoft Office-like ribbon-
based user interface (UI). The revamped UI offers a modern, tabbed view of erwin DM's 
functions and uses graphical buttons to represent them. Other offerings of the new UI 
include:

A Quick Access Toolbar

UI themes, font size, and component direction setting

Tabbed diagram window arrangement

The following picture gives you an idea of the difference in the UI appearance between 
2020 R1 and earlier versions of erwin DM:

Apart from the enhancements mentioned above, the placement of several functions has 
been rearranged on the ribbon (earlier, menu). Also, the icons representing several of them 
have been updated to reflect a modern look.
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For more information about the changes, refer to the following sections:

Ribbon

Quick Access Toolbar

Options to set Style, Font, and Component Direction

Tabbed Diagram Window

Vertical Split Window Arrangement

Target Database Selection

Toolbar Icons
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UI Components

The following components of erwin Data Modeler's (DM) are either new or have undergone 
a facelift:

Ribbon

The ribbon (earlier, menu) is a collection of all the functions and actions of erwin DM. These 
functions and actions are categorized into tabs and represented graphically using icons.

The following table shows the mapping between erwin DM 2019 R1 menu and erwin 
DM 2020 R1 ribbon:

Component
2019 R1

Location on 
Menu

2020 R1
Location on Ribbon/Toolbar

Model Templates File Home
erwin DM NoSQL File > erwin Edge Tools > Launch erwin DM NoSQL
Mart components File > Mart Mart
Editing options Edit Home
Toolbox toolbar View > Toolbars Home
Logical Model View Display Toolbar
Physical Model View Display Toolbar
Windows View > Windows View > Panes
Vertical Split NA View > Vertical Split
Review Changes Actions Mart
Manage Name Hardening Actions Tools
Model Naming Options Actions Tools
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Component
2019 R1

Location on 
Menu

2020 R1
Location on Ribbon/Toolbar

Query Tool NA Tools
erwin DM Scheduler NA Tools
Customize Tools Quick Access Toolbar
Manage Windows Window View
Cascade Window View
Tile Window View
Arrange Icons Window View
Diagram selector Window Editor pane-toggle using model specific tabs.
Bridges NA Tools

Quick Access Toolbar

The Quick Access Toolbar (Standard)is located at the top-left corner of the workspace. 

It contains a group of shortcut buttons for common tasks, such as creating, opening, saving, 
and printing a model; and undo / redo actions. 

Options to set Style, Font, and Component Direction

The Options button is located at the top-right corner of the workspace and enables you to 
manage the appearance of erwin DM user interface (UI) . You can set the color scheme, 
font size, panes and controls, and window size of erwin DM using these options.

Tabbed Diagram Window

In case of multiple open models, the diagram window displays all the models in a tabbed 
view.
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Vertical Split Window Arrangement

The Vertical Split option is located on the View tab of the ribbon. It arranges all the open 
models vertically, side-by-side.

Target Database Selection

Apart from the usual option to change the Target Database, an additional, quick option is loc-
ated on erwin DM's status bar.

Clicking the database name  opens the erwin Data Modeler -- Target Server dialog box.
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Toolbar Icons

As part of the facelift, several icons used in erwin Data Modeler (DM) have been updated. 
While ribbon icons  have self-explanatory labels, toolbar icons have tooltips. To make it 
easier for you to adapt, the following table lists the updated toolbar icons:

Toolbar Icon Function

Toolbox
The icons available on the Toolbox toolbar 
depend on the selection you make on Display 
toolbar > Logical/Physical Selector.

Create table

Materialized Query Table

Create view

Create identifying relationship

Create non-Identifying Relationship

Create an annotation

Create complete sub-category

Create many-to-many relationship

Zoom

Set zoom to 100%

Zoom model to fit the window

Zoom model to the selected area

Launch the Zoom Tool
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Toolbar Icon Function

Display

Switch to table display level

Switch to primary key display level

Switch to column display level

Switch to keys display level

Switch to comment display level
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Toolbar Icon Function

Mart

Connect to mart

Disconnect from mart

Launch Catalog Manager

Launch Session Manager

Change password

Open mart model

Save mart model

Save as mart model

Merge model

Lock mart model

Review changes made to mart model

Refresh mart model
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Toolbar Icon Function

Layout

Perform a circular layout

Perform a hierarchical layout

Perform an orthogonal layout

Perform a symmetric layout

Perform a tree layout

Reset relationship paths

Reset objects to automatic sizing

Preserve layout
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erwin DM Scheduler

One of the major features of erwin Data Modeler (DM) is its capability to reverse engineer 
from databases. However, you have to run reverse engineering (RE) processes manually and 
limit them to your work day. Thus, during the RE process, the other features of erwin DM 
are unavailable for use. Also, to configure and run another RE process, one needs to wait 
until the first process is complete.

erwin DM Scheduler enables you to schedule RE jobs in advance and run them without super-
vision. Thus, improving the original capability of reverse engineering. A live log keeps you 
updated about the job status.

Additionally, you can configure the scheduler to save reverse engineered models to a pre-
defined location on your device and on the Mart.

Note: You need administrative privileges to be able to use erwin DM Scheduler.

For more information about erwin DM Scheduler and its capabilities, refer to its doc-
umentation.

erwin DM Scheduler is one of the components in erwin Data Modeler (DM) installer.

http://erwin.com/bookshelf/public_html/2020R1/Content/Tools/Scheduler/Introduction.html
http://erwin.com/bookshelf/public_html/2020R1/Content/Tools/Scheduler/Introduction.html
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Installing this component adds erwin DM Scheduler Service to erwin Data Modeler under 
the Tools tab.
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Scheduling Jobs

Once you have installed erwin DM Scheduler, follow these steps to access and use it:

 1. Start erwin Data Modeler (DM).
Note: To be able to use the Scheduler, ensure that you run the DM as an admin-
istrator. 

 2. On the ribbon, click the Tools tab.

 3. Click erwin DM Scheduler.
This opens the Scheduler in a new window.

 4. Create an event in one of the following ways:

 l On the ribbon, under the Home tab, click New.

 l In the Calendar view, double-click a time slot under the day of your choice.

 l In the Calendar view, right-click a time slot under the day of your choice and 
click Add new event.
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The erwin DM Scheduler Event Details dialog box opens.

 5. Enter a Job Name.

 6. Select the Start Time and End Time.
Alternatively, to schedule an all day RE job, select the All day event check box .
Also, to schedule an RE job immediately, select the Schedule Now check box. 
Note: 

Jobs are run serially. Hence, schedule a reasonable job duration. Ensure that 
you consider the DB, its size, and the approximate job duration of the current 
jobs, and then schedule a new job accordingly.

Also, in case of multiple jobs scheduled at the same time with the Schedule Now 
option, it randomly selects a job to run. Therefore, it is recommended that you 
do not schedule multiple jobs to run at the same time.

 7. Select the Database to reverse engineer from and its version.
Note: If you set Redshift as the database, ensure that you do the following:
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 1. On the ODBC Data Source Administrator dialog box, go to the System DNS tab.

 2. Select the Redshift data source and click Configure. The Amazon Redshift ODBC 
Driver DSN Setup dialog box opens.

 3. Under Encrypt Password For, ensure that the All Users of This Machine check 
box is selected.

 8. To set reverse engineering options, click Reverse Engineer.
The Reverse Engineer - Set Options dialog box is displayed. For more information, 
refer to the Setting Reverse Engineering Options topic.

http://erwin.com/bookshelf/public_html/2019R2/Content/Tools/Scheduler/Setting_Reverse_Engineering_Options.html
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 9. Select the appropriate options and click Next.
The DBMS Connection dialog box is displayed.

 10. Enter your credentials and click Connect.

 11. Click OK.
Your RE job is scheduled. It runs as configured, and the job status and its event log is 
displayed.
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Depending on the settings you make and the job duration that you set, the job tile dis-
plays the following information about the job:

Name

Status

Start and end times

Run time
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Productivity Enhancements

Several enhancements have been implemented to improve  productivity and usage exper-
ience as follows:

Load Diagram with speed mode

Supertype-Subtype Transformation

Quick Complete Compare

These options are available on the Tools > Options dialog box.
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Load Diagram with Speed Mode

Diagrams that contain a large number of relationships between a relatively smaller number 
of entities take a long time to render. The Load Diagram with speed mode option lets you 
bypass relationship-related diagram rendering and loads the model first. Thus, accelerating 
the diagram load process.

Note: Using this option opens the model with an improper layout. To correct the layout, run 
the layout operation (Orthogonal Layout) manually after the model is loaded.

Supertype-Subtype Transformation

When you run Supertype-Subtype RollUp process via erwin Data Modeler (DM) > Actions > 
Transformations > Supertype-Subtype RollUp, only a single, rolled-up state is maintained 
for the involved entities on logical and physical sides.

The Supertype-Subtype Transformation option enables you to maintain two states of rela-
tionships between entities. On the logical side, it maintains the involved entities. Whereas, 
on the physical side, it maintains the rolled-up entity.

For this option to take effect, do the following:

 1. In erwin DM, on the Tools tab, click Options.
The Options dialog box opens.

 2. In the Diagram section, select Supertype-Subtype Transformation.

 3. Click OK.
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 4. On the Logical side of your model, right-click the Subtype symbol and click Properties.
The Subtype Symbol Editor opens.

 5. Under Transformation Type, select RollUp.
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 6. Click Close.
Supertype-subtype rollup transformation is applied on the Physical side of your model.

Note: For an already transformed target entity, any newly added non-key attributes in the 
child entity on Logical side are not rolled-up automatically. To roll-up the new attributes, 
rerun the roll-up action on the Logical side as follows:

 1. On the Attribute Editor, clear the Logical Only check box and click Close.

 2. On the Subtype Symbol Editor, set the Transformation Type to RollUp and click Close.

Quick Complete Compare

The Quick Complete Compare option lets you to bypass the hidden properties comparison. 
Thus, accelerating the complete compare process. There are two ways to set up quick com-
plete compare:

Complete Compare Wizard:

 1. In erwin DM, go to Actions > Complete Compare.
The Type Selection dialog box opens.

 2. Click Type Selection.

 3. In the Option Set drop-down list, select Speed Option Set.
This option set is based on an analysis of frequently used objects during Complete 
Compare.

Quick Complete Compare:

 1. In erwin DM, go to Tools > Options.
The Options dialog box opens.

 2. Select Quick Complete Compare.
The Option Set on the Type Selection dialog box is set to Speed Option Set.       
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Query Tool

The Query Tool provides a convenient way to execute SQL SELECT queries against a model 
in erwin Data Modeler (DM), a model in a mart, or against a database catalog. You can 
execute a query against the objects and properties in the model, the metadata defining 
those objects and properties, and the action log that records the changes that are made to 
your model during the modeling session.

To access the Query Tool, do the following:

 1. Start erwin Data Modeler (DM).

 2. On the ribbon, click the Tools tab.

 3. Click  (Query Tool).

 4. Enter your query in the Query box, or click the paste button on the toolbar to paste a 
query from another source.
Note: Before you can execute a query you must be connected to erwin ODBC or to a 
database.

 l Click Execute  on the toolbar.
The results of query execution are displayed in the Results box.

For more information about the Query Tool, refer to its documentation.

http://erwin.com/bookshelf/public_html/2019R2/Content/User Guides/erwin Help/The_Query_Tool.html
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Licensing

erwin Licensing allows you to check out your concurrent licenses for a long term.

When you first open erwin Data Modeler (DM), the erwin Data Modeler Licensing dialog 
box opens.
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Here, select  Long-Term Check-Out and set the Expiry Date.

Other than the above update, following enhancements have been made to Licensing:

Optional network domain name and subnet IP-based usage restrictions

erwin Data Modeler edition-based licensing

Contact your license administrator to configure these.
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DBMS Support

erwin Data Modeler (DM) now supports Redshift 1.0 and Db2 LUW 11.1 as target databases. 
Also, erwin DM and erwin Mart Server (MS) are now certified to work with Microsoft SQL 
Server 2019 and PostgreSQL v9.6.15, v10.10, and v11.5.

Redshift Object Support

CTAS

Databases

Functions

Groups

Libraries

Permissions

Schemas

Tables

Users

Views

For more information, refer to the Redshift Property Editors topic.

Db2 LUW Object Support

Storage Group object support has been added

Table properties have been updated to support organization types and period defin-
ition

Column properties have been updated to support new data types and constraints

Materialized query table support has been updated to include Replication as a method 
of maintaining query options

For more information, refer to the Db2 LUW Property Editors topic.

http://erwin.com/bookshelf/public_html/2019R2/Content/User Guides/erwin Help/Redshift_Property_Editors.html
http://erwin.com/bookshelf/public_html/2019R2/Content/User Guides/erwin Help/DB2_LUW_Property_Editors.html
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